Back to overview
Downtime

Server Turkey (PenDC) | Fastupload.Net and Fastupload OPUS Guard are down

Aug 12, 2025 at 9:31pm UTC
Affected services
Server Turkey (PenDC) | Fastupload.Net
Fastupload OPUS Guard

Resolved
Aug 12, 2025 at 9:40pm UTC

Server Turkey (PenDC) | Fastupload.Net and Fastupload OPUS Guard recovered.

Created
Aug 12, 2025 at 9:31pm UTC

Server Turkey (PenDC) | Fastupload.Net and Fastupload OPUS Guard went down.